Joysticks/buttons not responding in games (maybe xin-mo troubles)
  • I'm new to the homebuilt arcade world.

    I managed to get everything wired up. I bought this joystick/button set;

    I think the USB interface is what is referred to as Xin-mo and google shows people have being having some trouble with the Xin-mo sets.

    I use the latest beta version of PiPLAY and everything installed perfectly. In the main menu I setup the controls by pressing Tab and bringing up the controls-config menu selecting 'all' and completing the setup rutine.

    On the player one side 8 buttons + exit_program button and of cause the joystick directions were successfully recognized and setup. On the player two side 8 buttons and joystick were successfully recognized and setup. I can use player one joystick and buttons to navigate PiPLAY menu. All good.

    But when I start Mame4all or advMame games (have not tried other emulators) the joystick or buttons do not respond at all. Only the keyboard keys work.

    Have I missed a switch somewhere?

    I thought the buttons and joystick would just work if the general setup made in the PiPLAY menu was successful.
  • mame4all has to be configured separately by pressing 'tab' while running a game. I was told that there was a whitespace issue with the advMame setup that should be resolved with the next update
  • Thank you for the reply. I will try that asap.
  • It worked just fine both in advMame and Mame4all but I will be sticking to Mame4all as games run very slow in advMame.
  • When I configure the joystick buttons in the main menu I select a button to exit_program but it does not work in any of the games? Has anybody had the same issue?
  • Excuse me for my English.
    I have a xin-mo and for mame4all only recognizes the first 16 buttons, all buttons of player 1 and first 6 buttons of player 2.
    My mame4all settings:
    player 1 - 6 buttons, 1 coin button, 1 player button, 1 exit button (9 buttons)
    player 2 - 6 buttons and 2 player button (this button is button 10 of xin-mo player 1)
  • That's normal... try my release of mame4all, I've patched it to support all the button of the xin-mo module ;)

    you can try my arcade distro too
  • @ian57:

    I have the same issue with advmame, do you also have a fix for that or an overview what had to be changed in mame4all? Maybe it also applies to advmame... :)
  • No advance mame is working good with the 2 player xinmo. Check my config file here

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!