PiPlay startup options configuration ~/.profile
  • Hi - sorry I'm completely new to Linux - but trying to learn.

    I've got a Pi 2 with Raspian and Openelec installed via NOOBS.

    On my Raspian partition I have installed PiPlay - but I do not want it to start automatically (although I must of set this following the Github instructions) - as I am going to be using other programs such as Moonlight.

    Any help would be appreciated... I have worked out the script below seems to control my startup options (as I had already setup TightVNC - and PiPlay seems to have added itself to that script.

    1) What bits do I remove to go back to loading directly to Raspian command prompt?

    2) Also once I have resolved this how do I easily launch PiPlay i.e. type PiPlay to launch it?


    # if running bash
    if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"

    # set PATH so it includes user's private bin if it exists
    if [ -d "$HOME/bin" ] ; then
    if [ "$DISPLAY" == "" ] && [ "$SSH_CLIENT" == "" ] && [ "$SSH_TTY" == "" ]; then
    sudo xboxdrv --silent --config /home/pi/pimame/config/xboxdrv_mapping.cfg --dbus
    cd /home/pi/pimame/pimame-menu/
    python launchmenu.py

    Thanks in advance for any help
  • OK - I see I've got this completely wrong - tightVNC is starting via it's own script - which is fine - I always want it to run. It seems the above script is purely for PiPlay.

    How do I stop it running?
  • ah, ok. so this is an easy one. Just put a # in front of these two lines so that they look like this:
    #cd /home/pi/pimame/pimame-menu/
    #python launchmenu.py

    In order to add a custom command that will quickly run piplay, do this:
    sudo nano /usr/bin/piplay

    add this to the newly created file:
    cd /home/pi/pimame/pimame-menu/
    python launchmenu.py

    Ctrl+O to save
    Ctrl+X to quit

    sudo chmod +x /usr/bin/piplay

    You may need to restart for this to take effect (I'm not near my pi right now, so I can't test). But you can now run piplay by simply typing piplay in the command line
  • Thanks for the reply - that seems to have worked :)!

    Also, this line...

    sudo xboxdrv --silent --config /home/pi/pimame/config/xboxdrv_mapping.cfg --dbus

    seems to configure my wired Xbox controller - but it doesn't allow me to use the D-PAD for games - in fact it's not even recognised in the controller configurator (TAB).

    How do I get the D-PAD to be recognised?

    Thanks again and all the best.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!