piplay image for berryboot?
  • Has anybody got any advice or an image for piplay which can be installed on berryboot? I have used berryboot to install openelec to run xbmc and I would like to install piplay as well. Help!!!
  • I have managed to get a berryboot image of an older version of pimame. I hope you should be able to update the pimame from the command line...
  • I am. I'm actually building the next version for NOOBS rather than Berryboot, but if there is demand, it shouldn't be an issue to make both.
  • That would be amazing. Your berryboot image of 0.7 worked so well but is there now way of simply converting the image to a squashfs image?
  • Indeed that would be amazing, I came here looking for a berryboot image too and this is great news!
    Do you have an estimate for the next build?
  • I do not, but I might as well make an image for berry boot now with 8 beta 3. Ill try to release it tomorrow
  • Amazing, cant wait for the image. I am also going to try and utilizes xbmc's ability to play retro games. There are some good tutorials how to install play emulators on youtube. So hopefully I can have the best of both worlds.
  • I forgot how easy it was to create berryboot images. I am currently uploading it to my webhost, so it should be up in a few hours. Ill add a link when its done.
  • Thanks so much. Cant wait to boot it. The pi is so useful now that I have xbmc and pimame. Let the fun begin.
  • Has anybody tried it on berryboot? I tried running it but after 40minutes I gave up. Gonna try again tomorrow and hopefully it will install if I leave it for longer.
  • It works! It is amazing. Quick Question? How do I get to the pi settings on piplay 8.3 to overclock it?
  • if you press escape to exit out of the menu, type sudo raspi-config and there will be the overclocking options.
  • you are a legend. I know I sound like a broken record but I am having trouble getting my two player joystick to work on pi play. It is a usb controlled arcade joystick set bought from ultracabs. It used to wrok fine with pimame 0.7. Do you have the sudo commands to install the joystick controller? and the jtest? I used to configure in the GUI but I am having trouble finding the program.
  • sudo apt-get install jtest
  • No joys, I have tried that. When I run jstest /dev/input/js0 two of the direction buttons wont pick up. I cant remember the program but there was a small program that I used to install the the gui where you can test and calibrate the joystick? Think it might be called gtk jtk I am not sure.
  • Think I found it jstet-gtk
  • I have tried a host of tutorials but I still cant manage to get player 1 and player 2' up and left button working.
  • The controller reads as a DWC OTG Controller
  • Correction it is a Xin-Mo controller...
  • Is there any good tutorial fpr convert Images to squash-images (for Berryboot)?
    I found one but it doesn't work for me (after kpartx I cant mount the loopfile because it has no partition-table???)

    That would be great if anybody can explain it to me or better link me to a good tutorial.

    Thanks a lot.

    P.S. PiPlay is great, but PiPlay and Raspbmc on one SD-Card with an bootloader is much more greater ;)
  • http://www.berryterminal.com/doku.php/berryboot/adding_custom_distributions

    On Ubuntu 14 this is what I did:

    $ sudo kpartx -av image_you_want_to_convert.img
    output: add map loop0p1 (252:5): 0 117187 linear /dev/loop0 1
    output: add map loop0p2 (252:6): 0 3493888 linear /dev/loop0 118784
    $ sudo mount /dev/mapper/loop0p2 /mnt
    $ sudo sed -i 's/^\/dev\/mmcblk/#\0/g' /mnt/etc/fstab
    $ sudo mksquashfs /mnt converted_image_for_berryboot.img -comp lzo -e lib/modules
    $ sudo umount /mnt
    $ sudo kpartx -d image_you_want_to_convert.img
  • Yep, thats the tutorial which I found and tried out.
    I am not sure if the error is with my Image (I tried raspbmc first) or the virtual Linux machine, but I can't mount on 2nd step. I got a error something like 'missing filesystem type'. I checked the loop0p2-File with fdisk & testdisk and there is no partition table on the file -> maybe thats why it isn't possible to mount it?
    I tried to mount with -t "vfat" (and other filesystems) and got always an Error that this fs is not aviable. I am tring almost 3 days to mount the loop0p2 but without success... :(

    The Raspbmc-Image is backuped from my SD-Card, it is konfigurated as I like it (also PiPlay 0.8.3) and I just want to merge this two Images to one SD-Card on Berryboot....
    I used the WinDiskImaager32 for backuping (also recovering on SD-Card). Maybe I did a mistake?
    Am I the only one with such problems mounting the Image in Linux?
  • I used berryboot to load openelec for xbmc and piplay 8.3 and it works fine. Was very easy to install the various systems using berryboot.
  • @werner
    I know, everybody say it is easy.... but maybe I am stupid or something is wrong with my
    Instalaltion/Images/Linux or what ever.

    I have a virtual (VMWare Workstation) Linux and two Images created with WinDisk32 from an existing and already configurated Raspberry-Installation.

    I run into troubles in the 2nd Step: mounting!
    My Linux-machine tells me that the disk file type is missing! When I add the '-t' Option with any filesystem-type I run into errors like 'unknowned' or 'not found'?

    I think my Image have no Filesystem because when I run fdisk or testdisk over the Image it shows me that a FS is missing.
    Any ideas?
  • I am a noob myself and if I were to give you advice I would format the sd card, put the berryboot files on your sd. Boot up and install raspbmc or any other system of your choice, then use a memory stick and install shea's piplay berryboot image (it is on one of my previous discussions) and try running it. It was quite easy for a beginner and I am just struggling with my Xin-Mo joistick otherwise no problems.
  • I went to digital ocean, and created a small ubuntu cloud server. it cost me like 2cents for the time I spent. I downloaded the image, installed the needed tools, and then just had it convert from there.
  • @Shea
    Any news on solving the Xin-Mo controller issues? My up and left buttons still do not want to work in piplay 0.8.3?
  • The xin-mo patch is already included in the 0.8.3 version. If you have wired the player 1 joysticks and buttons 1&2 correctly, then it will work in the PiPlay front end. There are pins that do not work so here is the link for the ones i used. I have my xin-mo working on both mame and SNES.


    Hope that helps ;-)
  • Ok, I found out that my Image created from my running Raspbmc is corrupted or something. The loop0p2-partition (this is a partition, right?) has no partition-table!
    I downloaded a untouched Image and the problem was solved. I run into another problems, but I think I damaged my Linux-Installation. After a new install everything worked fine. Now I will try to install it on berryboot...but thats another story then ;)
    Thanks a lot!
  • @hinchhinch
    your dropbox image has been removed?
  • what bothers me is that my joysticks worked fine with pimame 0.7 and now it wont work with piplay 0.8.3
  • @hinchhinch
    Is there any way you can email or send me the image of how you wired your xin mo controllers to work?
  • @wernernagel2005 - I grabbed Hinch's pic just in case it came in handy later. Here's a link you can grab it from. If you want me to take it down just let me know Hinch.

  • Nah that's cool, I didn't realise it had changed.. Thanks chad ;-)
    This was for the 8.0.3 version. The pins that worked were different with the 7.10, so I expect this will change again when the new version when it comes out.
  • You guys are awesome, let the rewiring begin...
  • Just a stupid question? Why does the pin setup change when a new version of piplay comes out?
  • @hinchhinch
    I rewired according to the diagram but p1 and 2 still no response for up and left direction so gonna have to rebuild the kernel. Thanks anyways
  • It should just work. If you go back to 0.7 does it work again?
  • Yes it does. I have installed piplay o.8.3 and xin mo 2 player joystick and up and left direction for both players dont work. I have re wired the controllers and up and left still dont work. Directions worked fine in pimame 0.7.1.
  • Hi wernernagel2005,
    I'm sorry, but If you have a Rasberry Pi, Piplay 0.8.3, a xin-mo encoder and it is wired correctly, I don't get why mine and others are working and yours isn't.. Silly question but are you sure it is Piplay 0.8.3 and not the earlier 0.8 versions? I see your post where you are compiling and it seems like a confusing mammoth task when mine has been easy to get mine running. I do hope you sort it soon so you can have a bit of Funtime playing it.. Good luck, Kristy ;-)
  • @hinchhinch

    Tell me about it. Im going to format the sd card and start over, if it doesnt work im going to recompile the kernel and if that fails im going to revert back to .7.10. Thanks for the help
  • @SSilver2k2, @ian57 and @hinchhinch. I made some progress. I reformatted my sd, did not use berryboot and installed a fresh copy of piplay 0.8.3. I have installed the update, jstest, evtest and jstest-gtk. I now have a fully working player 1 on my two player xin mo. But unfortunately player 2 is not working, neither directions or buttons. Does anybody have any idea how to fix this?
  • That's great, I'm sure you are feeling stoked with that ;-)
    Do you mean player 2 is not working in the Piplay menu? (If so, I'm sure only player 1 is supposed to)..Have you tried to play a MAME game?
  • I played a few games and player one works, no response for player 2. Evtest and jatest-gtk shows no response for 2nd player buttons. Will check the wiring again but i do think its a software problem
  • maybe check the ground daisy chain on player two or change to a different ground pin on the xin-mo.... i am surprised that no buttons work at all.
  • Yes it's very strange... in most of my test, when xin-mo is detected and supported with evtest... all is working. As hinchhinch said you should check your wiring... perhaps the second mass is not on the right pin... it's easy to make this mistake.
  • I get an "error copying file" every time i use beryboot+piplay-0.8-beta3-bb.img

    Anyone knows why?
  • Perhaps you SD is smaller than the piplay image? Have you tried another SD card?
  • I fix it. I just reinstalled berryboot and piplay to usb (not sd) hard drive..
  • Any chance we can have the latest berryboot image for the latest beta? thanks

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!