PiPlay has stopped working on start up.
  • I'm a little perplexed by this seeing nothing has changed and all of a sudden PiPlay has stopped working when i boot it up. The error that comes up in the shell is "sqliet3.OperationalError: database or disk is full". Why would this happen all of a sudden and anyone know a remedy without doing a fresh install?


  • It looks like it's probably a corrupt database. You can give this a try in command line:
    cd /home/pi/pimame/pimame-menu/database
    mv config.db config-backup.db
    sqlite3 config-backup.db ".dump" | sqlite3 config.db

    if that doesn't work, you can download the original config database here:

    then just copy it to the /home/pi/pimame/pimame-menu/database folder. You may lose some of your settings, but it should get you back up and running.
  • Fantastic, will give that a try mate. Cheers very much, will let you know how i get on.
  • Hmm yeah still no luck after trying the top suggestion. I cleared some unused roms in case its a space issues. Now i get the error "sqlite3.OperationalError: no such table: options" rather than the database or disk is full.

    Dont seem to be able to fire up Debian with the startx command otherwise i'd have tried the original config database option.


  • ok, try this:
    wget https://github.com/ssilverm/pimame-menu/blob/master/database/config.db?raw=true -O /home/pi/pimame/pimame-menu/database/config.db
    That will download the file and save it to the correct location

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!