Raspberry Pi 3!
  • Here is the official link

    Raspberry Pi 3 is now on sale for $35 and here are some of the specs:
    A 1.2GHz 64-bit quad-core ARM Cortex-A53 CPU (~10x the performance of Raspberry Pi 1)
    Integrated 802.11n wireless LAN and Bluetooth 4.1
    Complete compatibility with Raspberry Pi 1 and 2

    My question is, what does this mean for the piplay community? What new emulators will this be able to handle, and would this allow for a more flashy Piplay GUI like the Hyperspin?

    Also, what do we need to do to get PiPlay working on the PI 3?
  • I went ahead and ordered it. $42 shipped. Not sure when it will actually arrive though.
  • is right, he brought the same thing to my attention when I tried to boot the PiPlay image on a Zero.

    My steps from the other thread, if anyone is interested:

    Start with a fresh install of Raspbian Jessie lite. It doesn't come with Python so install it with
    sudo apt-get install python3-pip
    You'll also need to install the pygame modele
    sudo apt-get install python-pygame
    and finally use the PiPlay installer here with
    git clone https://github.com/ssilverm/piplay-installer
    cd piplay-installer
    bash installer.sh

    You could also use the regular Raspbian Jessie image, but I knew I wouldn't need the GUI, so I went with the lite image.
  • I installed the regular version of Jessie, not the lite. Once booted I followed ran these commands:
    git clone https://github.com/ssilverm/piplay-installer
    cd piplay-installer
    bash installer.sh

    They seemed to run correctly.
    After that I rebooted and all I get is a black screen with the flashing underscore in the top left corner, it will not respond to any keyboard input. Any suggestions?
    I will wipe the SD and re install jessie again in the meantime.
  • I just started with the Pi so i used Jessie. I added the password for my network and ran the installer. After the boot, all I'm getting is the flashing cursor like krayzielilsmoki.
  • I'm not sure if the full version of Jessie comes with pygame installed or not, but you could try installing it just in case with
    sudo apt-get install python-pygame

  • Thanks for the reply dollerbill, I will try this after work today and report back.
  • It does.
    I got I working last night.
    I loaded Jessie booting to thr desktop.
    I setup the location, time and network settings.
    Then, opening the terminal window, I used config to set the next boot to the $ prompt.
    Lastly, I ran the three lines from above for piplay installer.
    Reboot and success.
  • Awesome! Cant wait to try when I get home.
  • Still no luck, I went into the boot menu and tried boot to text with auto login, it booted to the command line saying that it was unable to launch the piplay menu. I tried changing boot options to boot into desktop and now Im back to the flashing underscore.
  • Anyone else that can give input on this issue?
  • I also had problems with the image downloaded PiPlay 0.8.0 Beta 9 on SD. It never booted, but a big square "raibow color" appeared still.
    Then I tried to install through Raspian ( not Lite ) console as explained in https://github.com/ssilverm/piplay-installer. After all that process I got that there was a mistake when it boots, something like an expected "fi".
    Then I realized that in "installer.sh" there was a mistake.
    it is on file:
    echo 'cd /home/pi/pimame/pimame-menu/' >> /home/pi/.profile
    echo 'python launchmenu.py' >> /home/pi/.profile

    echo 'fi' >> /home/pi/.profile

    sudo apt-get -y install supervisor
    it should be on file:
    echo 'cd /home/pi/pimame/pimame-menu/' >> /home/pi/.profile
    echo 'python launchmenu.py' >> /home/pi/.profile

    echo 'fi' >> /home/pi/.profile


    sudo apt-get -y install supervisor

    With that change on file it worked for me.
  • @jusips
    So after I do
    git clone https://github.com/ssilverm/piplay-installer

    Wait for it to download then I should edit the installer.sh file itself

    I need to look for the lines you listed and switch the location of "fi"

    after that I should do

    cd piplay-installer
    bash installer.sh

    is this correct?
  • Genesis emu is not working:

    export LD_LIBRARY_PATH=/home/pi/pimame/dispmanx/build/.libs/ && /home/pi/pimame/emulators/dgen-sdl-1.32/dgen
    /home/pi/pimame/emulators/dgen-sdl-1.32/dgen: error while loading shared libraries: libarchive.so.12: cannot open shared object file: No such file or directory

    I have installed libarchive-dev and libarchive13. Any clue?
  • Yes, krayzielilsmoki, that's it!
    Although I have done it through console connected via SSH (with putty). I guess it is the same than doing it console window on graphic interface.

    good luck !
  • @cjbriere - did you ever figure out how to get the Genesis emulator working on jessie lite? I'm trying to get it, but haven't had any luck
  • I haven't had any luck with RasPi3 at all, I'm still on the 2 until we have an official PiPlay build that I can do a fresh install with.
  • I still haven't gotten a 3 yet, but I've picked up where we left off and am working on getting the libretro emulators working with piplay.
  • Hi @cjbriere , @mholgatem

    I have made dgen to work on raspbian jessie, try to follow this steps, they worked for me:

    1. sudo apt-get install libarchive-dev
    2. sudo ln -s /usr/lib/arm-linux-gnueabihf/libarchive.so.13 /usr/lib/arm-linux-gnueabihf/libarchive.so.12
    3. sudo apt-get install libts-0.0-0

    Then try to start dgen. For me its working !!! :D
  • Not working for me. It all most works on my Raspberry Pi 3. I installed 2016-05-27-raspbian-jessie.img then updated it. Rebooted, then did the commands from:



    git clone https://github.com/ssilverm/piplay-installer
    cd piplay-installer
    bash installer.sh

    Reboot and the PiPLAY comes up after about a sec. of the Raspberry Pi 3 desktop.

    No arrow keys do any thing. If I move around the mouse the desktop can show on clicks and I can do things.

    So it's like the PiPlay menu is over the desktop but PiPlay don't work.

    Any one know what I can do?

    Just want the C64 part to work on this.

    PiPlay worked on a older Raspberry Pi but playing a C64 game it's just to slow so go the Pi 3.

    -Raymond Day

    A little update. Reading more on this seen how it said in the Pi configuration made it boot to command line. I looked it up and found how here:


    Rebooted and now it's working.

    So looks like can't run the desktop.

    Can't the piplay-installer be updated to it auto boots to the command line shell?

    -Raymond Day

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!