PiPlay 0.8 Beta 8 Testers Wanted (Not for faint of heart)

    Hey All,
    I'm ready to release the new PiPlay image, but I would like some people to test out the update script.
    This script could mess up your install so DON'T test if you don't want to have to reflash your card later.

    Type these two commands to update:

    wget pimame.org/update_beta.sh
    bash update_beta.sh

    I've tested it myself, and it looks like it works, but I would like some more eyes on it. This will upgrade your install to work on a Pi2 as well.


  • Hi Shea, took about 1 1/2 hrs to update (Adsl2). Loads fine and Looks great.
    I have 2 problems though.
    1. When I use the tab to set ALL controls, when it comes to mapping LEFT, it then skips the option to map UP and the same goes with RIGHT/DOWN
    2. SNES is still not mapping the 2nd player.
    Hope that helps and if you have any ideas how to fix, please share!
  • Shea

    Just run the upgrade as per above. I have a PI2 and its a fresh install as of yesterday. So my system wasnt 100% working prior to the upgrade.

    However so far it upgraded and booted as per normal and all of the roms are there.
  • Mines taking a while also, I'm on 80mb Fibre! I think it's a processing issue/hosting issue rather than a problem.
  • I'm also getting continuous "waiting for dbus address to appear"
    I'm sure I've seen this on the forum already, so going to investigate.
  • ;) Cheers. I followed most of that, and it worked.

    Just need to work out why my Xbox controller doesn't work now!
    Wireless, with the official wireless dongle.

    xboxdrv gives : Error
    USBController::()USBController: libusb_open() failed: LIBUSB_ERROR_ACCESS

    If I sudo it, I get :

    Couldn't claim the USB Interface: LIBUSB_ERROR_BUSY

    Run rmmod xpad, and it says command not found
    Sudo killall xboxdrv gives xboxdrv:no process found.


    I'm a filthy n00b. Never Mind.
  • @hinchhinch - are you using a xin-mo type encoder?
  • Guys, have updated my install from the icon on the menu, and almost everything seems to be ok, except that i don't have any ROMs in any of the Emuls, and also, some of the emus are gone as well as some custom configs for launching some of them.
    Checked the config.yaml file and it's the way i left it. I've read somewhere this new version is moving the configs to SQL.
    The question is, how do i reconfigure the system now to reproduce my settings in the SQL database? My ROMs are not in the SD card, but in a 250GB external HD!
    I tried the remote web interface, but there's no new admin features available, like in the preview on the main page of the blog. Should i update again on the console?

  • Was playing around with the new upgrade just before. Its not storing any of my controller settings or theme settings.
  • @mugo - you are correct. config.yaml is gone. Everything is stored in sqlite databases. They are now located at /home/pi/pimame/pimame-menu/database/config.db

    The new web frontend should be available to you right now if you upgraded to .8b8

    @hinchhinch - snes probably isn't working because you need to manually set the xin-mo flag in the config file. I'm working on the other problem. it sounds like a debounce (basically same key is being set twice).
  • @mugo - you can't update from the menu. You have to run the script I posted above. This isn't ready for production, just testing.
  • Guys, thank you very much for the replies.

    I executed the update script again, this time from the console, but as root. Now i have, what seems to be a known issue, with the omxplayer at startup. I've found some workarounds on other forums, that consist to delay the execution of omxplayer, whats not exactly what i want as a lot of the boot process log is shown on screen, but seems to work for now. Of course, this is not a problem with the PiPlay script, it's my fault.

    PiPlay was still not working after this time because the pi user files where not updated.

    Ran it a second time as user pi, and now everything is working very well! Thanks a lot for this update! Lots of very usefull features!

    I just wish there was some documentation explaining things like how to add new systems emulators to the menu, with their icons, scraping IDs, etc.

    Lots of the games in my collection seems to be correctly identified by the scrapper, as their descriptions are present, but most of them have no picture. I don't know why. Most of them already have the pics files in the same folder that was being used before, by the old scrapper (i'm not really sure if the scrapper has changed that much, if at all).

    Anyway, now, it seems to take a little longer to open the frontend so i can choose the system, and seems to take the same amout of time when i quit a game and get back to the menu, than it took before, in the b7. But the new features are well worth it!

    And as i said, i have a pretty big ROMs collection, of about 8000 - 9000 games.

    Thanks again! If there is any other test i can do to help, please let me know.

    I can say the new web interface work as a charm, as i have configured retroarch to be the emulator in various systems, and also my ROMs folder is in an external HD running NTFS. Everything is working, except for the extra systems. I get an error from launchmenu.py (and other scripts called by the previous) that i suspect is because these systems don't have correct IDs for the images in menu. I setted them not visible and the menu is working again.
  • I can't access sudo startx at all now to change any settings.... when ESC is pressed, the "waiting for dubs address to appear" is continuous. I will reflash my card and try the update again.
  • @mugo- the documentation will come when we officially roll this new version out. As for not being able to add menu items, that was a bug. so thanks. I've already fixed it and will be pushing it to the repo soon.

    The new scraper has changed quite a bit. See this post

    As for images not showing, if the image is .jpg or .png and named exactly the same as the rom file (ex- 'super mario world.zip' and 'super mario world.jpg') it should show up. Alternatively, you can download the supported images (links in the post mentioned above) and unzip them to your images folder, then run the scraper again. you will probably want to run the scraper from the command line like this:
    python /home/pi/pimame/pimame-menu/scraper/scrape_script.py --clean_slate True
    That will re-scrape all of your games, not just the unmatched/new ones
  • @mholgatem - Thanks! Yes, i looked at the images folder after my last post and remembered that i have renamed almost all of my ROMs files to have no spaces. So, obviously, the names for ROMs and images don't match. I'll fix this. Thanks a lot for the link to the image files and for the scraper advice!

    Very glad to know you found a new bug and managed to fix it!

    I have the same problem other guys are reporting on the distro upgrade. I shouldn't have done that. When i have time i'll try to start over with a clean install. But it hurts to think about installing all the emuls over again.

    Pi Play is already the best frontend for gaming on the RPI. I like Emulation Station very much for it's nice interface and features, but it's slow. I think now Pi Menu is on par, but much faster! ES takes about 6 minutes to boot on my system because of the many ROMs i have.
  • I've just installed this beta update on my Raspberry Pi2. It works fine. I've just one issue. 2 controllers both on one player (Keyboard and Xbox 360 controller-wired)
  • Also I forget to talk about the fact that with this version you can't upload roms. I keep getting 500 internal server error when I go to rom uploader page.
  • I have no problem with the ROM uploader on my RPi B (not +). All the features of the new Web Interface work very well.

    Now, as i'm writting here again, the field where the descriptions appear in this new interface version is static, and various descriptions are way bigger than this field, so they get cut at the bottom of the screen.

    Is this the expected behaviour so far?

    By the way, the new search/favourite feature is AMAZING!

  • I'll backup my image and try it out! :D
  • @mugo. yes, as of right now, some of the descriptions will be longer. If you find that the text is too large, you can edit the font size in each individual theme by editing /home/pi/pimame/pimame-menu/themes/theme_name/theme.yaml
    find 'info_font_size:' and change it to a smaller size. Eventually we will implement scrolling text, but for now, I just wanted to focus on functionality.
  • The "Install MAME" doesn't seem to be working. I installed it and the emulator won't show up...
  • @Pristopher - did you run the updater from inside piplay or did you use this method:
    wget pimame.org/update_beta.sh
    bash update_beta.sh

    if you used the latter, you should also be able to go into the web frontend and set mame4all and advmame to visible.
  • Hey don't know if this should be in features request but can you upload an image for original pi and one for pi 2?
  • This update will work for both a pi and a pi2
  • For the pi2 are we going to include the emulator for n64? Good work and thanks.
  • @mholgatem I did it using wget and bash. I'm trying to access some areas on the web frontend, but I get 505 errors...
  • Fixed it manually from the config.yaml file. I scraped the roms but I still don't get the description from any of them...
  • @Pristopher - it sounds like yours didn't update correctly. the config.yaml shouldn't do anything anymore. it should be converted to the databases now (They are located in /home/pi/pimame/pimame-menu/database/)
  • It seems so... I don't have the database on my directory. Any suggestions besides a fresh image?
  • I'm not sure. That'd be a question for @SSilver2k2. Maybe he has an idea
  • @Pristopher - have you ran the update script as pi, instead as root? I had a similar problem in the first try because i automaticaly executed the script as root. This way it tries to update files at the home folder for root user, instead of the home folder for pi user.
  • @mugo I'm pretty sure it was as pi.
  • Ok, just a report to the developers, as i don't know if they are aware:

    As some emulators generates save files for some given game (i.e. gpSP, PCSX, etc) the number of files in the ROMs folder is changed. So when you get beack to the menu it's reporting that given system needs a new scraper run.

    So, everytime you play a different game in that system, you need to go thru a long scrapping session again, and that's boring.

    Maybe you guys already have plans for this. It would be great if PiPlay would filter files to just look for new ROMs files.

    In fact, this would be also a great new feature for the menu itself. Just consider in the ROMs folder, the files whose extensions are specified in the menu configuration for that given system.
  • So I ran the update from the piplay menu and it updated, not sure if you meant that to happen. Anyway, how do I modify the databases so I can flip the visibility of the different emulators?

  • I'm not involved with the project, but i can share my experience so far.

    You need to run the update from the console, as mentioned in the first post. Updating from the menu doesn't work.

    After this, you'll have the most recent web interface. So you can connect to the database management through a web browser typing the IP address of your Pi box.
  • So what's the proper install order for all this?

    I'm using Pi 2 so the images are not an option.

    I installed Raspbian and everything boots fine.

    I checked out the pimame-installer, ran it, and restarted.

    Downloaded update_beta.sh and found it was looking for a ~/pimame directory that's not there. The 7.10 installer didn't put anything there.

    What am I missing in this whole process?
  • Decided to take one my my old Pis and upgrade it that way then put the SD card in the Pi 2. All good now!
  • Ok I took a fresh copy of noobs installed rasperian os and then updated and command line downloaded PiPlay and then updated to the beta. Works great. Fast as well. Only problem is that when I try to configure my joysticks (xin-mo I push to the left and it flashes through the up and on to the right without any more input). Any help on how to resove the problem would be great. Running on pi2.
  • @Gavat4r - I have already fixed the controller config (as far as I am able to test without an actual xin-mo). It's just awaiting a merge into the repo. If you want to give it a shot, you just need to copy pmcontrollerconfig.py and pmcontrols.py from my repo to:

    if you want to give it a shot and let me know how it worked.
  • @mholgatem - I am attempting to change the files but cannot get WinSCP to connect to my pi - tells me access denied. what the best way to update the files. sorry to be a pain.
  • does it give you an error code when it says access denied? I've never used WinSCP, I always use Filezilla, but either should work.
  • ok I am getting closer! I have installed Filezilla and can log into the pi. I can navigate to the directory and can get to the files on your repo. How do I move the file from your repo to the pi via (Filezila) windows? or is there a easier way? sorry this all a little bit new to me!
  • @mholgatem - I have installed this version and it works well (https://gist.github.com/2ba54c7c82d9355f74ca.git) but I can't make my keyboard and my joystick (Xbox 360 wired controller) work together as 2 distinct player with the Pisnes emulator. You can find my snes9x.cfg file in the previous link.
  • @fluxb0x - you will need to manually configure your snes9x.cfg file. Edit lines 20-31 for your keyboard configuration (use this file to get the key codes)

    so if you want spacebar to be the player 2 'A' button, line 20 should look like this:
    A_2 = 32
  • I know that we talked about it in the other thread, but for anyone that hasn't seen the scummvm thread, please take a look.
  • Burned a clean new image, upgraded, ran and... I love it! Specially the "slide" theme. I'm going to load my roms and try it out in a while and maybe customize the theme a little bit. I'm also going to add a StartX Menu Item.
  • @Pristopher - glad you like it! I can't wait to see what you have in mind! If you make any new themes that you'd like to share, just let me know and I'll host it on my repo.
  • So, I loaded my roms and scraped them. The description show up fine, but not the images. Also, when I'm browsing through the rom lists it crashes. For some reason, I forced audio through HDMI and it didn't seem to work. I think I'll wait a little for the image launch.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!